02/12/2011

Some remarks about installing Sametime 8.5.2

UPDATE  7th March 2012
As written in the comments, Frank wrote a new version of his slides, dated December 21st 2011.
I have not read it yet, so I'm not sure if my post is outdated or if it's still useful in some parts. Your call :-)



ORIGINAL POST

Some weeks ago I installed a pilot Sametime 8.5.2 Standard infrastructure following the REALLY GREAT guide written by Frank Altenburg from IBM Germany.

Frank did a great job describing the step-by-step procedure on Windows OS.


After the installation I wrote some remarks about Frank's guide, hoping that it will be useful to other people doing it for the first time (I already forworded my notes to Frank).

--- START ---

Copy/paste command from the guide:
beware copy/paste text from the PDF file, because strange chars are included in the paste.
Even if I used a text editor to make the paste command, I had to remove the "strange" double quotes included in the commands (maybe a German char?), replacing them with "normal" double quotes chars.


PAGE 11: THIS IS VERY IMPORTANT!
item 3, about the Media Manager NOT working when installing it with a DNS Alias.
That's really important and, in my opinion, should be stressed even more.
In my experience, I overlooked it (my fault!), and continued the all installation until the end.

BUT then when I arrived to test the web A/V plug-in, it did not worked (connecting...).
Even I tried to enable the debug for the A/V plug-in but that was useless to understand the cause of the problem. I just realized that it was a connection problem.
Luckily for some reason I remembered the remark in page 11 (survival instinct):


PAGE 177: TESTING THE WEB CHAT
I tried to test this feature at this time of the installation but it was not working at that time:
I decided to continue the installation with STEP 12 (page 178, post installation) to set the Windows services and dependencies and virtual hosts, and restarted the server. After the restart, the webchat was working fine.



PAGE 346: SERVICE NAME ERROR
in the SC command text, the name of the service IS  "IBMWAS70Service – STMediaServer_NA", not "IBMWAS70Service – STMediaServer_NS".
But luckily the screen-shot shows the correct command.


PAGE 390: DIRECTORY NAME (bold) where to create the Plugin directory, did not exist.
The dir name
“C:\IBM\WebSphere\AppServer\
profiles\webchatSTPPNProfile1\installedApps\sametimeSSCCell\SametimeProxy.ear\stproxyweb.war”,
it did not exist in my installation (at following the order of installation of the guide...):
I found out the dir name should be:
“C:\IBM\WebSphere\AppServer\profiles\webchatSTPPNProfile1\installedApps\webchatSSCCell\SametimeProxy.ear\stproxyweb.war”


PAGE 391: WRONG URL TO CHECK THE VERSION OF THE PLUGIN
The correct URL is
http://webchat.renovations.com/stwebclient/Plugin/VersionInfo.txt


PAGE 405: JUST A REMARK
This is not wrong, just some people maybe did not create any rooms in advance, maybe they do not know how to do that, and the example URL makes sense only for your server not for the guy making the installation: I was so tired during this step that I thought that the URL should exist also in my installation ;-)
My fault.

--- END ---

No comments: